Investigating Scheduling Center Issues
Incident Report for Scheduling Center
Resolved
This incident has been resolved.
Posted May 26, 2020 - 09:29 MDT
Identified
Our team has identified a potential problem with the Scheduling Center's rate limiter, and we are already investigating the issue. A fix is being deployed.

We'll post updates with more information as soon as possible.
Posted May 26, 2020 - 09:06 MDT
This incident affected: Scheduling Center and API.