Investigating Scheduling Center & Oxifresh.com Issues
Incident Report for Scheduling Center
Resolved
The issue at Cloudflare seems to be resolved & all sites are back online.
Posted Jul 02, 2019 - 08:13 MDT
Identified
The issue seems to be upstream at Cloudflare (https://www.cloudflarestatus.com/), who is working on the problem now.
Posted Jul 02, 2019 - 08:03 MDT
Update
We are continuing to investigate this issue.
Posted Jul 02, 2019 - 07:52 MDT
Investigating
Our team has identified a potential problem with the Scheduling Center & Oxifresh.com, and we are already investigating the issue.

We'll post updates with more information as soon as possible.
Posted Jul 02, 2019 - 07:51 MDT
This incident affected: Scheduling Center, API, www.oxifresh.com, www.reviewoxifresh.com, and www.oxifreshfranchise.com.