Investigating Oxifresh.com Issues
Incident Report for Scheduling Center
Resolved
This incident has been resolved.
Posted Mar 23, 2020 - 12:21 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 23, 2020 - 12:12 MDT
Identified
Additional fixes are being implemented as the site remains unstable. We'll continue to update as we make progress.
Posted Mar 23, 2020 - 12:01 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 23, 2020 - 11:54 MDT
Identified
Our team has identified a potential problem with www.oxifresh.com, and we are already investigating the issue.

We'll post updates with more information as soon as possible.
Posted Mar 23, 2020 - 11:54 MDT
This incident affected: www.oxifresh.com.