Investigating Oxifresh.com Issues
Incident Report for Scheduling Center
Resolved
This incident has been resolved.
Posted Feb 20, 2020 - 19:35 MST
Investigating
Our team has identified a potential problem with www.oxifresh.com, and we are already investigating the issue.

We'll post updates with more information as soon as possible.
Posted Feb 20, 2020 - 19:28 MST
This incident affected: www.oxifresh.com.