Issue With Franconnect Login
Incident Report for Scheduling Center
Resolved
This incident has been resolved.
Posted Jan 30, 2020 - 10:31 MST
Identified
It looks like the Login page for Franconnect is currently experiencing issues with it's SSL certificate. We're currently working with them to get this resolved.

In the meantime Owners and Corporate users can still login to their Schedules directly at:

https://crm.oxifresh.com/
Posted Jan 30, 2020 - 08:47 MST
This incident affected: www.oxifresh.com.