Investigating Scheduling Center Performance Issues
Incident Report for Scheduling Center
Resolved
This incident has been resolved.
Posted Nov 06, 2019 - 14:07 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 06, 2019 - 13:59 MST
Investigating
Our team has identified some performance problems with the Scheduling Center, and we are already investigating the issue.

We'll post updates with more information as soon as possible.
Posted Nov 06, 2019 - 13:57 MST
This incident affected: Scheduling Center and API.