Investigating Scheduling Center Issues
Incident Report for Scheduling Center
Resolved
Services have been restored, we're continuing to monitor performance to be safe.
Posted Jan 15, 2019 - 21:06 MST
Investigating
Our team has identified a potential problem with the Scheduling Center, and we are already investigating the issue.

We'll post updates with more information as soon as possible.
Posted Jan 15, 2019 - 20:52 MST
This incident affected: Scheduling Center and API.