Investigating Scheduling Center Issues
Incident Report for Scheduling Center
Resolved
This incident has been resolved.
Posted Apr 17, 2019 - 17:19 MDT
Investigating
Our team has identified a potential problem with the Scheduling Center, and we are already investigating the issue.

We'll post updates with more information as soon as possible.
Posted Apr 17, 2019 - 17:15 MDT
This incident affected: Scheduling Center and API.