Investigating Oxifresh.com Issues
Incident Report for Scheduling Center
Resolved
This incident has been resolved.
Posted Jan 15, 2020 - 16:33 MST
Update
We are continuing to monitor for any further issues.
Posted Jan 15, 2020 - 10:24 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 15, 2020 - 10:24 MST
Identified
Our team has identified a degraded performance with www.oxifresh.com, and we are already investigating the issue.

We'll post updates with more information as soon as possible.
Posted Jan 15, 2020 - 10:20 MST
This incident affected: www.oxifresh.com.