Investigating Oxifresh.com Issues
Incident Report for Scheduling Center
Resolved
This incident has been resolved.
Posted Feb 21, 2020 - 09:46 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 21, 2020 - 09:25 MST
Investigating
Our team has identified intermittent performance issues with www.oxifresh.com, and we are already investigating the issue.

We'll post updates with more information as soon as possible.
Posted Feb 21, 2020 - 09:14 MST
This incident affected: www.oxifresh.com.